using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\""|\')(?<key>[^""]*)(?:\""|\')(?=:)(?:\:\s*)(?:\""|\')?(?<value>true|false|[0-9a-zA-Z\+\-\,\.\$]*)";
string input = @"[
{
""_id"": ""56af331efbeca6240c61b2ca"",
""index"": 120000,
""guid"": ""bedb2018-c017-429E-b520-696ea3666692"",
""isActive"": false,
""balance"": ""$2,202,350"",
""object"": {
""name"": ""alexander"",
""lastname"": ""lang""
}
}
]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}