const regex = /(?:\"|\')(?<key>[^"]*)(?:\"|\')(?=:)(?:\:\s*)(?:\"|\')?(?<value>true|false|[0-9a-zA-Z\+\-\,\.\$]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\"|\\\')(?<key>[^"]*)(?:\\"|\\\')(?=:)(?:\\:\\s*)(?:\\"|\\\')?(?<value>true|false|[0-9a-zA-Z\\+\\-\\,\\.\\$]*)', 'gm')
const str = `[
{
"_id": "56af331efbeca6240c61b2ca",
"index": 120000,
"guid": "bedb2018-c017-429E-b520-696ea3666692",
"isActive": false,
"balance": "\$2,202,350",
"object": {
"name": "alexander",
"lastname": "lang"
}
}
]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}