# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\"|\')(?<key>[^\"]*)(?:\"|\')(?=:)(?:\:\s*)(?:\"|\')?(?<value>true|false|[0-9a-zA-Z\+\-\,\.\$]*)"
test_str = ("[\n"
" {\n"
" \"_id\": \"56af331efbeca6240c61b2ca\",\n"
" \"index\": 120000,\n"
" \"guid\": \"bedb2018-c017-429E-b520-696ea3666692\",\n"
" \"isActive\": false,\n"
" \"balance\": \"$2,202,350\",\n"
" \"object\": {\n"
" \"name\": \"alexander\",\n"
" \"lastname\": \"lang\"\n"
" }\n"
" }\n"
"]\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.