#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?uis)(\S)- "
Local $sString = "dit is een auto- matische test van onge- lofelijk lange woorden." & @CRLF & _
"Dit mag niet hitten - Boom!"
Local $sSubst = "$1­"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)