import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(\S)- "#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
dit is een auto- matische test van onge- lofelijk lange woorden.
Dit mag niet hitten - Boom!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1­"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)