// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?uis)(\S)- ").unwrap();
let string = "dit is een auto- matische test van onge- lofelijk lange woorden.
Dit mag niet hitten - Boom!";
let substitution = "$1­";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}