import re
regex = re.compile(r"^==\h*Upgrade Notice\h*==(?:(?:\R(?!=\h*\d+\.\d+\.\d+\h*=$).*)*\R=\h*(\d+\.\d+\.\d+)\h*=$\s*){1}^((?:\h*\S.*(?:\R\h*\S.*)*)+)", flags=re.MULTILINE)
test_str = ("Some stuff before this notice like a changelog with versioning and explanation text.\n\n"
"== Upgrade Notice ==\n\n"
"= 1.3.0 =\n\n"
"When using Master Pro, 1.3.0 is the new minimal required version!\n"
"This is a test\n\n"
"= 1.1.0 =\n\n"
"When using Master Pro, 1.1.0 is the new minimal required version!\n"
"this is\n"
"a test\n\n"
"= 1.0.0 =\n\n"
"No upgrade - just install :)\n"
"another thest\n\n"
"[See changelog for all versions](https://plugins.svn.wordpress.org/master-pro/trunk/CHANGELOG.md).")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")