package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\b(one|two|three)?)(.*\b(four|five|six)?)(.*\b(seven|eight|nine)?)`)
var str = `one two three four five six seven eight nine
two three four six seven eight`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}