// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*\b(one|two|three)?)(.*\b(four|five|six)?)(.*\b(seven|eight|nine)?)").unwrap();
let string = "one two three four five six seven eight nine
two three four six seven eight";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}