re = /(.*\b(one|two|three)?)(.*\b(four|five|six)?)(.*\b(seven|eight|nine)?)/m
str = 'one two three four five six seven eight nine
two three four six seven eight'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end