using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w :].*?(?=;|$)";
string input = @"key_1: some text, maybe a comma, ending in a semicolon; key_2: text with no ending semicolon";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}