re = /[\w :].*?(?=;|$)/
str = 'key_1: some text, maybe a comma, ending in a semicolon; key_2: text with no ending semicolon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end