$re = '/[\w :].*?(?=;|$)/';
$str = 'key_1: some text, maybe a comma, ending in a semicolon; key_2: text with no ending semicolon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);