using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\xa9\\xa20(\\xa?\d+\\xa?\d+)";
string input = @"\x01\x80\x00\x04_\xa9\xa20\x01\x19\x00";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}