re = /\\xa9\\xa20(\\xa?\d+\\xa?\d+)/
str = '\\x01\\x80\\x00\\x04_\\xa9\\xa20\\x01\\x19\\x00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end