const regex = new RegExp('\\\\xa9\\\\xa20(\\\\xa?\\d+\\\\xa?\\d+)', 'gs')
const str = `\\x01\\x80\\x00\\x04_\\xa9\\xa20\\x01\\x19\\x00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}