package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\,\d+)*(\.\d{1,4})?$`)
var str = `2,000,000
200000.0000
200
200.00000
2,000.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}