$re = '/^\d+(\,\d+)*(\.\d{1,4})?$/m';
$str = '2,000,000
200000.0000
200
200.00000
2,000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);