const regex = /^\d+(\,\d+)*(\.\d{1,4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(\\,\\d+)*(\\.\\d{1,4})?$', 'gm')
const str = `2,000,000
200000.0000
200
200.00000
2,000.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}