using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/Date\(\d+(\-\d+)?\)\/";
string input = @"/Date(1439213503381)/
/Date(1439213503381-0400)/
/Date(1439213503381-0700)/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}