const regex = /\/Date\(\d+(\-\d+)?\)\//gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/Date\\(\\d+(\\-\\d+)?\\)\\\/', 'gi')
const str = `/Date(1439213503381)/
/Date(1439213503381-0400)/
/Date(1439213503381-0700)/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}