re = /\/Date\(\d+(\-\d+)?\)\//i
str = '/Date(1439213503381)/
/Date(1439213503381-0400)/
/Date(1439213503381-0700)/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end