use strict;
my $str = 'Size: 40; Color: 30
<span class=\'tooltip\' data-tooltip=\'The Size of a Unit is controlled by the Color of the Unit.\'>Size</span>: 40; <span class=\'tooltip\' data-tooltip=\'The Color of a Unit is a standard Setting.\'>Color</span>: 30';
my $regex = qr/(Color)(?!(?:<|.+'>))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}