re = /(Color)(?!(?:<|.+'>))/m
str = 'Size: 40; Color: 30
<span class=\'tooltip\' data-tooltip=\'The Size of a Unit is controlled by the Color of the Unit.\'>Size</span>: 40; <span class=\'tooltip\' data-tooltip=\'The Color of a Unit is a standard Setting.\'>Color</span>: 30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end