#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^SELINUXTYPE=(\w+)$"
Local $sString = "# This file controls the state of SELinux on the system. " & @CRLF & _
"# SELINUX= can take one of these three values: " & @CRLF & _
"# enforcing - SELinux security policy is enforced. " & @CRLF & _
"# permissive - SELinux prints warnings instead of enforcing. " & @CRLF & _
"# disabled - No SELinux policy is loaded. " & @CRLF & _
"SELINUX=enforcing " & @CRLF & _
"# SELINUXTYPE= can take one of three two values: " & @CRLF & _
"# targeted - Targeted processes are protected, " & @CRLF & _
"# minimum - Modification of targeted policy. Only selected processes are protected. " & @CRLF & _
"# mls - Multi Level Security protection. " & @CRLF & _
"SELINUXTYPE=targeted" & @CRLF & _
"" & @CRLF & _
"# This file controls the state of SELinux on the system. " & @CRLF & _
"# SELINUX= can take one of these three values: " & @CRLF & _
"# enforcing - SELinux security policy is enforced. " & @CRLF & _
"# permissive - SELinux prints warnings instead of enforcing. " & @CRLF & _
"# disabled - No SELinux policy is loaded. " & @CRLF & _
"SELINUX=enforcing " & @CRLF & _
"# SELINUXTYPE= can take one of three two values: " & @CRLF & _
"# targeted - Targeted processes are protected, " & @CRLF & _
"# minimum - Modification of targeted policy. Only selected processes are protected. " & @CRLF & _
"# mls - Multi Level Security protection. " & @CRLF & _
"SELINUXTYPE=targeted " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")