import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^SELINUXTYPE=(\\w+)$";
final String string = "# This file controls the state of SELinux on the system. \n"
+ "# SELINUX= can take one of these three values: \n"
+ "# enforcing - SELinux security policy is enforced. \n"
+ "# permissive - SELinux prints warnings instead of enforcing. \n"
+ "# disabled - No SELinux policy is loaded. \n"
+ "SELINUX=enforcing \n"
+ "# SELINUXTYPE= can take one of three two values: \n"
+ "# targeted - Targeted processes are protected, \n"
+ "# minimum - Modification of targeted policy. Only selected processes are protected. \n"
+ "# mls - Multi Level Security protection. \n"
+ "SELINUXTYPE=targeted\n\n"
+ "# This file controls the state of SELinux on the system. \n"
+ "# SELINUX= can take one of these three values: \n"
+ "# enforcing - SELinux security policy is enforced. \n"
+ "# permissive - SELinux prints warnings instead of enforcing. \n"
+ "# disabled - No SELinux policy is loaded. \n"
+ "SELINUX=enforcing \n"
+ "# SELINUXTYPE= can take one of three two values: \n"
+ "# targeted - Targeted processes are protected, \n"
+ "# minimum - Modification of targeted policy. Only selected processes are protected. \n"
+ "# mls - Multi Level Security protection. \n"
+ "SELINUXTYPE=targeted \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}