import re
regex = re.compile(r"(?m)^SELINUXTYPE=(\w+)$", flags=re.MULTILINE)
test_str = ("# This file controls the state of SELinux on the system. \n"
"# SELINUX= can take one of these three values: \n"
"# enforcing - SELinux security policy is enforced. \n"
"# permissive - SELinux prints warnings instead of enforcing. \n"
"# disabled - No SELinux policy is loaded. \n"
"SELINUX=enforcing \n"
"# SELINUXTYPE= can take one of three two values: \n"
"# targeted - Targeted processes are protected, \n"
"# minimum - Modification of targeted policy. Only selected processes are protected. \n"
"# mls - Multi Level Security protection. \n"
"SELINUXTYPE=targeted\n\n"
"# This file controls the state of SELinux on the system. \n"
"# SELINUX= can take one of these three values: \n"
"# enforcing - SELinux security policy is enforced. \n"
"# permissive - SELinux prints warnings instead of enforcing. \n"
"# disabled - No SELinux policy is loaded. \n"
"SELINUX=enforcing \n"
"# SELINUXTYPE= can take one of three two values: \n"
"# targeted - Targeted processes are protected, \n"
"# minimum - Modification of targeted policy. Only selected processes are protected. \n"
"# mls - Multi Level Security protection. \n"
"SELINUXTYPE=targeted \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")