using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+[,.]\d+|(\d+)";
string input = @"abc111.222dfg333hfg44,55jhkjhkh78789sdfdsfsdf4dfdsfds";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}