re = /\d+[,.]\d+|(\d+)/
str = 'abc111.222dfg333hfg44,55jhkjhkh78789sdfdsfsdf4dfdsfds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end