$re = '/\d+[,.]\d+|(\d+)/';
$str = 'abc111.222dfg333hfg44,55jhkjhkh78789sdfdsfsdf4dfdsfds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);