package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(-[a-z]+)?`)
var str = `8-911-1234567
8-495-1-234-zzz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}