$re = '/\d+(-[a-z]+)?/';
$str = '8-911-1234567
8-495-1-234-zzz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);