const regex = /\d+(-[a-z]+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(-[a-z]+)?', 'g')
const str = `8-911-1234567
8-495-1-234-zzz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}