#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+)(?:-)(?![a-z])"
Local $sString = "zzz-8-911-aaa-1234567" & @CRLF & _
"8-495-1-234-zzz"
Local $sSubst = "$1|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)