const regex = /(\d+)(?:-)(?![a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(?:-)(?![a-z])', 'g')
const str = `zzz-8-911-aaa-1234567
8-495-1-234-zzz`;
const subst = `$1|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);