$re = '/(\W|^)(html|CSS|JavaScript)(\W|$)/i';
$str = 'HTML HTMLDDD d é muito usado nos dias de hoje, juntamente com o HTML usamos JavaScript e CSS...CSS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);