re = /(\W|^)(html|CSS|JavaScript)(\W|$)/i
str = 'HTML HTMLDDD d é muito usado nos dias de hoje, juntamente com o HTML usamos JavaScript e CSS...CSS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end