package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?|[а-яё]+([a-z]+)|[a-z]+([а-яё]+))[a-zа-яё]*`)
var str = `Пocтaвкa мяco гoвядины, бecкостнoe для нужд государственного бюджетного учреждения здравоохранения Республики Башкортостан Инфекционная клиническая больница № 4 города Уфа `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}