const regex = /(?|[а-яё]+([a-z]+)|[a-z]+([а-яё]+))[a-zа-яё]*/igu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|[а-яё]+([a-z]+)|[a-z]+([а-яё]+))[a-zа-яё]*', 'igu')
const str = `Пocтaвкa мяco гoвядины, бecкостнoe для нужд государственного бюджетного учреждения здравоохранения Республики Башкортостан Инфекционная клиническая больница № 4 города Уфа `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}