re = /(?|[а-яё]+([a-z]+)|[a-z]+([а-яё]+))[a-zа-яё]*/i
str = 'Пocтaвкa мяco гoвядины, бecкостнoe для нужд государственного бюджетного учреждения здравоохранения Республики Башкортостан Инфекционная клиническая больница № 4 города Уфа '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end