const regex = /^(?:[0-1]?[0-9]|2[0-4])?[0-9]{0,6}(?:\.[0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-1]?[0-9]|2[0-4])?[0-9]{0,6}(?:\\.[0-9]+)?$', 'gm')
const str = `15999999.99
24999999.99
1
25000000.01
1000
123456789
560000.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}