$re = '/^(?:[0-1]?[0-9]|2[0-4])?[0-9]{0,6}(?:\.[0-9]+)?$/m';
$str = '15999999.99
24999999.99
1
25000000.01
1000
123456789
560000.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);