#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=(myMethod){1})(.*)somethingelse"
Local $sString = "private myMethod" & @CRLF & _
"do something" & @CRLF & _
"" & @CRLF & _
"private myMethod" & @CRLF & _
"do somethingelse"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")