const regex = /(?<=(myMethod){1})(.*)somethingelse/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(myMethod){1})(.*)somethingelse', 's')
const str = `private myMethod
do something
private myMethod
do somethingelse`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}