re = /(?<=(myMethod){1})(.*)somethingelse/
str = 'private myMethod
do something
private myMethod
do somethingelse'
# Print the match result
str.match(re) do |match|
puts match.to_s
end