using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[link.*?href=""(.*?)?"".*?title=""(.*?)"".*?class=""(.*?)"".*?\](.*?)\[\/link\]";
string input = @"[link href=""somehref"" title=""sometitle"" class=""someclas""]Text[/link][link href=""somehref"" title=""sometitle"" class=""someclas""]Text2[/link]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}