import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[link.*?href=\"(.*?)?\".*?title=\"(.*?)\".*?class=\"(.*?)\".*?\\](.*?)\\[\\/link\\]";
final String string = "[link href=\"somehref\" title=\"sometitle\" class=\"someclas\"]Text[/link][link href=\"somehref\" title=\"sometitle\" class=\"someclas\"]Text2[/link]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}