// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\[link.*?href="(.*?)?".*?title="(.*?)".*?class="(.*?)".*?\](.*?)\[\/link\]"#).unwrap();
let string = "[link href=\"somehref\" title=\"sometitle\" class=\"someclas\"]Text[/link][link href=\"somehref\" title=\"sometitle\" class=\"someclas\"]Text2[/link]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}