const regex = new RegExp('(?<=[а-яё])(?=[А-ЯЁ])', 'gm')
const str = `приветРегулярка`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);