$re = '/(?<=[а-яё])(?=[А-ЯЁ])/m';
$str = 'приветРегулярка';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;